Firefox Plugin for Inquiry Pro

Author Message
George Miller 01/14/2017 10:16 am
Hey there, the firefox plugin for inquiry pro will not install as it is unsigned and does not work with the current version of Firefox. By when will you provide an updated version? George