Page formatting messed up

Author Message
Rado 06/30/2013 02:56 pm

Inquiry Pro (latest version) is messing up the formatting of pages on this site when saved:

http://www.contentparadise.com/productDetails.aspx?id=21444

Andrey Filatkin 07/01/2013 01:40 am
Hi,

I cannot reproduce this. Can you please backup the saved page and send it to me (andrey.filatkin@metaproducts.com)? What is your Windows and IE versions?

Best regards,
Andrey Filatkin
MP Staff
Rado 07/01/2013 06:27 pm

Well I had the problem in both XP SP3 (IE8) and Windows 7/64 Ultimate (IE10) yesterday, and trying again today now the problem was still there.

But after deleting the browser history in both and then refreshing the page, the problem seem to have gone. Maybe caused by a temporary html code error on the site that has been fixed now?
Rado 07/01/2013 07:43 pm

Well the problem is back again. I have however found a way to consistently produce either a correctly formatted saved page or a misformatted saved page. Works in both XP and Win 7:

First load the original page in the browser, then click the Refresh button /without/ clicking ctrl. Then save the page in IQ. Now right click on the saved page in the IQ tree view and select "Browse in a new tab". The page is now misformatted.

Now delete the saved page. This time you /press ctrl/ while clicking the Refresh button on the original page. Then save the page in IQ and again view in a new tab. The saved page is now corretly formatted.

Note that it's important that you delete the saved page each time you shift between the two methods, if you just click "Replace" in the dialog box it doesn't seem to update the saved page, for some reason.









Andrey Filatkin 07/02/2013 01:59 am
Hi,

This page is loaded part by part during a some time. Probably you start saving before all parts are loaded. At least I was able to get only such misformatting.

Best regards,
Andrey Filatkin
MP Staff
Rado 07/02/2013 11:02 am
Well I've tried to wait several minutes before saving the page, but it's often misformatted anyway. But doing a Refresh with ctrl pressed always fixes the problem. Maybe the page doesn't always load completely in the browser before you do that?


Andrey Filatkin 07/02/2013 11:46 am
Maybe. I need to look at this saved page. Please backup it and send to me (andrey.filatkin@metaproducts.com)
Or you can try to save the page from Google Chrome. Chrome addon saves pages in other way from IE and it can give another result.
Rado 07/02/2013 03:05 pm
Well it's not really a problem now that I know how to fix it. Just wondering what causes it, looks to me like it's a problem with IE and not Inquiry. I've also tried Chrome and it seems to work fine here.

I'll sent you the files anyway in case you might be interested in looking into it.
Andrey Filatkin 07/03/2013 01:43 am
Thank you! I see now some of files is truncated to 2048 bytes and it is reason for misformatting. I fixed this problem about year ago. But now I must to revise this.