Bug?

Author Message
Richard Andersen 04/21/2005 08:55 am

Hi,

I think there is a bug in Inquiry:

Whan you click an URL link in a program and it open in MSIE, the icon on the taskbar first blinks, and then remains highlighted, until you click it to view the page. This is perfectly normal.

However, when Inquiry is installed, and you already have one or more MSIE windows open, then the icon for the last opened window also gets highlighted together with the a new one. So you have to click both icons to turn off their highlight.

It`s especially annoying when you, as I do, use Autohide for the taskbar, since it won`t hide again before all highlighted icons are clicked and turned off. So I have to click an extra time every time now.

thanks,
Rich


Richard Andersen 04/21/2005 09:52 am

Forgot to say, I`m using Win 2000 SP4...

Richard Andersen 04/23/2005 03:25 pm


Some additional info:

It seems as if the problem generally only occurs when Inquiry is open as sidebar in one or several of the open MSIE windows. There seem to be occasional exceptions to this however, but I can`t see any particular pattern for these.






Richard Andersen 04/23/2005 04:33 pm

More info:

It seems that only certain programs triggers this behaviour, when you launch MSIE from a link in a text message in one of these programs. That is, programs that does not bring MSIE to front when you click a link from within them.

Currently I know of two programs that works this way:

Agent 2.x newsreader
http://forteinc.com

Pegasus Mail
http://pmail.com

Outlook Express however does not seem to trigger it, since it brings MSIE to front when you click an URL link (not sure if it`s always the case, since I`m not normally using OE, I just did a few tests for how it behaved in this respect).

Richard Andersen 04/23/2005 04:36 pm


> Pegasus Mail
> http://pmail.com

sorry, http://www.pmail.com

Oleg Chernavin 04/25/2005 04:55 am
Thank you for the details. We just tried to reproduce the problem with PegasusMail under Windows XP, but everything worked correctly and when clicking on a link, a new MS IE window opened and showed in the front automatically. Maybe there is a kind of MS IE setting?

Best regards,
Oleg Chernavin
MP Staff
Rich 04/28/2005 11:36 am
> Thank you for the details. We just tried to reproduce the problem with PegasusMail under Windows XP, but everything worked correctly and when clicking on a link, a new MS IE window opened and showed in the front automatically. Maybe there is a kind of MS IE setting?
>

Thanks. I`ve now tried to install Inquiry plus Agent and Pegasus on my graphics computer, which is identical to this one, but has different software installed. I`m not able to reproduce the problem there. MSIE always comes to front when I click the links, and the double icon thing does not appear.

So I suspect it`s some software conflict that causes it, on this machine. I`ll try to see if I can find out what it is.

But Inquiry seems to be involved in any case in some way, since the double icon thing only happens when the Inquiry sidebar is open in one of the open MSIE windows. What`s going on here I`m not really sure.

Rich
Oleg Chernavin 04/28/2005 11:47 am
Yes, if you will find what exactly causes the issue, this may help us to fix it.

Thank you!

Oleg.