Couple of Problems

Author Message
Defenestration 07/16/2004 01:33 pm
1) There is a problem when pausing a download of loarge files when the number of bytes downloaded is high. eg. I was downloading a 28MB file and had to puase it a few times during the download. When only a few percent had been downloaded there were no problems. When I tried pausing it about about 90% it crashed with an Floating point divide error.

2) Occasionally the percent complete can disappear briefly from the title bar, only to reappear again. This only happens very occasionally and doesn`t seem to affect the download in any way.



Defenestration 07/16/2004 02:03 pm
An update to (2): It disappears when the percentage is updated and is still 0%. It re-appears when the percentage is 1%. This is probably not noticeable on ADSL connections, but is very noticeable when downloading a large file with dial-up. Should be easy to fix.
Alexander 07/19/2004 10:35 am
Dear Sir / Madam,

Thank you very much for your report.
Could you please write me the number of your Download Express version?
Which percentage indicator do you mean?
Thank you for your help.

Best regards,
Alexander Bednyakov
MP Staff
Defenestration 07/19/2004 10:40 pm

I`m using the latest version 1.6 of Download Express.

The percentage in the window title bar of the download window.
Defenestration 07/22/2004 10:52 am
Alexander,

I tried the new version you mailed me but the problem with the percentage in the title bar still exists.

To demonstrate the problem try downloading a large (20MB) file over a dial-up connection (or limit the download speed to 1000 bytes per second).

When the download first starts, "0%" is very briefly displayed in the download windows title bar. Then, while the file actually starts downloading the percentage (ie. 0%) is *not* displayed in the title bar while it remains at 0%. As soon as 1% of the file has been downloaded the percentage *is* then displayed in the title bar for the rest of the download.

This is not a major problem and should be simple to fix. It`s noticeable though.

I will let you know about the problem with DE crashing when suspending a download after 10MB has been downloaded.



displayed
Alexander 07/23/2004 03:06 am
Could you please write us your Windows version?
Unfortunately, we cannot reproduce this 0% problem.

Thank you,
Alexander
Defenestration 07/23/2004 03:48 am
> Could you please write us your Windows version?
> Unfortunately, we cannot reproduce this 0% problem.
> > Thank you,
> Alexander

I`m using WinXP Home SP1.

I have noticed this problem on previous versions as well.

It doesn`t sound like a OS/system problem to me. Are you sure you are not doing something differently in the code during a download when the percentage is 0% ? As mentioned before, the 0% is displayed initially right at the start (ie. the connection has been made, but no bytes have been received), but as soon as the download has actually begun (ie. some bytes are received, as indicated by the first number below the progress bar) the 0% disappears. When it reaches 1% it appears again, making me think there is something in the code that does not display the percentage if it is 0%.
Alexander 07/23/2004 10:31 am
Could you please test the updated version?
http://www.metaproducts.com/download/desetup.exe
Please write us about the result. Thank you!

Alexander
Defenestration 07/24/2004 07:06 am
The problem still exists.

I have sent you an e-mail about it.
Defenestration 07/25/2004 08:59 am
Well, I tried to send you an e-mail but all my e-mails to metaproducts are being blocked by the anti-spam blocklist you are using. I`m on AOL and I`m guessing that someone has used their e-mail account to send out spam. Therefore other users on AOL will have similar problems contacting metaproducts by e-mail.

The problem does not seem to exist if I send e-mail via the Web interface so I will try that.

However, can you change the anti-spam blocklist you use so I do not have to use the web interface when using e-mail to contact you.

Thanks