Author Message
Edward 03/29/2006 07:00 am
I`ve had DLE halt twice now at 99% during a download and report the filesize incorrectly.

I`m running a fresh install of windowsMe on a DSL connection.
I`ve allowed DLE three transfer threads.

The first resume attempt to resume ended in the file vanishing into limbo - I have no idea where it went, DLE just started downloading from 0%

The second attempt ended with DLE reporting 99% of a 666mb file done, but only 150mb was pulled. The resume appears to have functioned this time, and I am attempting to pull the remainder of the file. I have captured screenshots as proof.

I am running the third attempt and will report back in an hour.

Edward 03/29/2006 07:00 am
> I am running the third attempt and will report back in an hour.
>

Same thing on the third try. Halt at 99%, disconnected the DSL modem.
*This* time, I reconnected, kliked pause, kliked resume, and it finished properly.

This is the url that I was pulling.

http://www.linuxiso.org/download.php/440/psyche-i386-disc2.iso

Alexander 03/29/2006 07:00 am
Dear Edward,

Thank you for your reports.
We are working on this problem test and fixing now.
It must be fixed in the next DE version.

Sincerely,
Alexander.
| Alexander Bednyakov
| Senior Developer
| MetaProducts Corporation
Gerald Cavin 03/29/2006 07:00 am
I`ve observed the same thing on my side (99% then halt), even with the new beta 1 version of DE 1.4
When I check the progress Tab, one of the treads has "Aborted" status.
This always happend with large files (more than 15MB)

Then I do a "pause" / "resume"; download start again but not from 99% (last try was from 60%)
My config is
Minimal thread size : 10
Connection timeout : 45
Pause : 60
Threads 5 for high speed

Thanks for your help
Alexander 03/29/2006 07:00 am
Dear Gerald Cavin,

Thank you for your report.
I sent you details on log file creation.
Please help us to fix this problem.

Thanks.
Alexander.
| Alexander Bednyakov
| Senior Developer
| MetaProducts Corporation
paul 03/29/2006 07:00 am
> Dear Gerald Cavin,
>
> Thank you for your report.
> I sent you details on log file creation.
> Please help us to fix this problem.
>
> Thanks.
> Alexander.
> | Alexander Bednyakov
> | Senior Developer
> | MetaProducts Corporation
> ---------------------------------------------------------------
Hi,

This program has done that too me 2 times and i have 30mb of corrupted files already!! It would be great if you could fix it! I Have Version 1.4 Beta 2, on a brand new dell running XP HOME , over dial-up.

For some reason when i use the disconnect and shutdown buttons, it corrupts the file and it doesn`t seem to save the file onto the hard drive before it shuts down!!!! I hope you can fix this soon, love the program!!!
Felix Atagong 03/29/2006 07:00 am
Using 1.4.0.193. tried to download a 700 mega file with 25 threads, all went well, all threads complete until the last one aborts at 99%. I switched over to 2xExplorer and saw that the temporary file was growing steadily for about 10 minutes (even with the download aborted). But then it halted at some 30000 bytes from the end. When I pressed pause and then F5 to retry, the program started again to download from about 400 mega on, so a loss of about 40%. Using XP home on a Dell Pentium 4.2, cable connection and Dutch version of the download utility.
Alexander 03/29/2006 07:00 am
Thank you for your reports.

We will fix these problems in Download Express 1.5 Release.

Sincerely,
Alexander.
| Alexander Bednyakov
| Senior Developer
| MetaProducts Corporation
David 03/29/2006 07:00 am
I have the same halt problem with the 1.5 service release. It halts at 99% and wont do anything. Then when I try to exit the program it wont quit. I end up forcing all of windows to quit. It normally picks up at 90% when I restart the computer and program.

I seem to have found the reason for my problem. I`m using Windows XP Home, IE6 and Norton SystemWorks 2004.

I knoticed that my Anti-virus software is having a problem with DE. The anti-virus program freezes DE to try to scan the download but the programs don`t seem to like each other.

To work around it, when DE halts at 99% I open my Anti-virus and scan the .de file for my download and then a minute later(I assume one of the programs is re-scanning the file) the file finishs downloading and the window closes and I have my file. (The file was 48.8MBs)

So either have your anti-virus program on when the file is about to complete or open it when DE has halted and scan the .de file.

Hope this helps.

> Thank you for your reports.
>
> We will fix these problems in Download Express 1.5 Release.
>
> Sincerely,
> Alexander.
> | Alexander Bednyakov
> | Senior Developer
> | MetaProducts Corporation
>
vince 03/29/2006 07:00 am
> I`ve had DLE halt twice now at 99% during a download and report the filesize incorrectly.
>
> I`m running a fresh install of windowsMe on a DSL connection.
> I`ve allowed DLE three transfer threads.
>
> The first resume attempt to resume ended in the file vanishing into limbo - I have no idea where it went, DLE just started downloading from 0%
>
> The second attempt ended with DLE reporting 99% of a 666mb file done, but only 150mb was pulled. The resume appears to have functioned this time, and I am attempting to pull the remainder of the file. I have captured screenshots as proof.
>
> I am running the third attempt and will report back in an hour.
>
>
I am using DLE 1.4 under W2K. Same problem. Smaller files download ok, over a few Mb`s it stops at 99%
When using Pause/Continue the downloaded size falls back to 31-39%.

Vince
Alexander 03/29/2006 07:00 am
Dear Vince,

Thank you for writing us.
Could you please create the downloading log file for one of these problem downloads?

To make the downloading log please download the logging.zip archive from
http://www.metaproducts.com/download/logging.zip
Please extract and open "Logging.reg" file. It will export the necessary parameter to Download Express` Registry entry.

Download Express will create the log file in the downloading folder. It will have the same name
as the downloaded file and the .LOG extension. When this problem repeats, please find the corresponding log file, pack it using WinZip or etc. program and email to support@metaproducts.com.
Then please use "NoLogging.reg" file to turn off the logging feature.

Thank you for your help.

Sincerely,
Alexander.
| Alexander Bednyakov
| Senior Developer
| MetaProducts Corporation

> I am using DLE 1.4 under W2K. Same problem. Smaller files download ok,
> over a few Mb`s it stops at 99%
> When using Pause/Continue the downloaded size falls back to 31-39%.
>
> Vince
Juan 03/29/2006 07:00 am
I have v 1.3 and is the first time i got this problem like yours. I was downloading a 260MB file and it was at 88% so i stopped it to resume later. So today i continued and it reached 99 but it just halt there so i pause it and resume but it just started at 20%, that was a waste of time. I hope this bug or problem get fix.
Alexander 03/29/2006 07:00 am
Dear Juan,

Thank you for writing us.
Could you please try the latest build from: http://www.metaproducts.com/download/betas/debsetup.exe ?
Please write us about the result. Thank you.

Sincerely,
Alexander.
| Alexander Bednyakov
| Senior Developer
| MetaProducts Corporation
Ali Hortacsu 03/29/2006 07:00 am
Let me clear you guys on this thing
after reaching 99% or even 100% DE and massdownloader doesn`t stop the download.
so what that means is although the proram shows 99-100% its actually at say 95%. well its not but bc of some thing in the way md & de are set up even if u`re connecting from billions of threads when the counter reaches 99% it slows it down leaving like 1 thread or half a thread. so it slows.

conclusion after reaching 99% de still is downloading the file
u can check this by going into the folder of the download and check the file size change.
this has been an issue of de and md. in earlier stages md would not even dl the rest of the piece but hopefully it at least dles it at a very low speed. so whatever`s left after 99% is dled at an enourmous slow speed. I dled desertcombat .7.exe 591mb I dled 99% of it in 4min 8MB/s and the rest took like 20min. but at the end its a complete very succesfull download. so be patient after 99%.

to the programmers of md & de please fix this problem. I like the fact that I can go up to 100threads that no other program supports but seriously this 99% thing blows. I usually use flashget. it allows 10 threads has a nice interface... i would like to switch to massdownloader if this thing gets resolved. (i`ve been looking at massdownloader since like the first build of it)...

Thanks....
Alexander 03/29/2006 07:00 am
Dear Ali Hortacsu,

Thank you for writing us.
Yes, I see the problem. We plan to change this in the next version of Download Express and then in Mass Downloader (after some tests.)
Thank you for your help.

Sincerely,
Alexander.
| Alexander Bednyakov
| MP Staff