Does Mass Downloader 3.7 need an upgrade?

Author Message
AlexanderBa 08/14/2009 08:41 am
Please tell what the exact version of Mass Downloader do you use.

AlexanderBa,
MP Staff.
EC Britz 08/14/2009 11:28 am
> Please tell what the exact version of Mass Downloader do you use.
>
> AlexanderBa,
> MP Staff.

I have uninstalled the program due to the problems mentioned. But liked it and would still buy it if I know how to find a fix. My version was downloaded less than a week ago from the Mass Downloader site. So it has to be the very latest version. I actually tried the update function and got a message that it was the latest update. I noticed that Explorer 7 but not Explorer 8 was listed in the list of supported browsers and browser versions. After noting that, I tried Mass Downloader while downloading from Explorer 8, and it worked. The program cannot be plugged into the latest 3.5 version of Firefox, that has been said by many customers in this forum. However, I do not need to use Firefox. I you can give me a link for the very latest update, and/or assure me that Mass Downloader will always work with Explorer 8 even though this browser version is not listed, I''ll re-install and buy.
AlexanderBa 08/20/2009 06:41 am
I wrote you a private message. Did you receive it?
You can download the latest version from:
http://www.metaproducts.com/download/mdsetup.exe
I advise you to download and install it over the existing version. It tested with IE 8 and FireFox 3.5.2.
You can also download FireFox plugin separately:
http://metaproducts.com/download/mpint.xpi
Its current version is 1.2.1. Please check.
We cannot assure that Mass Downloader will smoothly work with them in future because sometimes manufacturers change own integration technologies. But we follow the latest updates of most popular browsers.

AlexanderBa,
MP Staff.