How to avoid sorting links without name when adding?

Author Message
Jan 02/24/2009 11:50 am
Hello.. There is one thing which has bothered me for a long time and I want to avoid.

When adding urls from either "Import->Urls from file" or by Pasting I get a selectionwindow telling
me to select urls to add.. which is fine by itself.

However, urls with no entry in the "Name" (this would be almost always when adding more than one) column gets sorted by url, which sometimes is very annoying, such as when the initial url itself has no significance and the urls has already been presorted.

How do I get MD to stop meddling with the sequence of the imported or pasted urls?
If it isn''t possible yet, may I suggest a "Don''t sort/Original sequence" button?

Regards
AlexanderBa 02/25/2009 11:13 am
The new beta version has been just released. We added the button you requested. Could you please try?
http://www.metaproducts.com/download/mdbsetup.exe
Thank you.
Jan 02/25/2009 04:14 pm
> The new beta version has been just released. We added the button you requested. Could you please try?
> http://www.metaproducts.com/download/mdbsetup.exe
> Thank you.

I didn''t notice an extra button at first, but it did initially show the proper order (very nice).
After some searching I found it and it seems to work perfectly :)
Thank you.

Jan
Jan 02/26/2009 08:13 am
Some observations, not related to the button itself but with the beta.

It seems that for some reason this version (b1) sometimes stops downloading at some random
point while showing the square icon next to the queue number, and it doesn''t seem possible to resume or restart without restarting the application. If I do this it sometimes silently crashes.
The speed on the Progress View seems to have been reduced a great deal (update once per second or something?).

I mention this as those are different from the 3.6.759 (although not unexpected as it''s a beta).
Alexander 02/26/2009 09:23 am
Jan,

Thank you for your report.
Is this happening with any download or with some certain ones? Could you please help us with hints on how to reproduce the problem?

Regarding the non existing button to sort adding links - please click the tiny down arrow located to the right side of the toolbar -> Add or Remove buttons -> Reset Toolbar.

Best regards,
Alexander Bednyakov
MP Staff
Jan 02/26/2009 06:55 pm
It doesn''t seem to be anything specific about it. The files which I attempted to download
was on the same domain, same filetype, similar size etc.. I''ve excluded MD and *.mass from AV/FW
scanning, in additon to exclude MD from content filtering so this should not have any effect.
I''ve also tried the downloads without FW or AV running at all (all related services was also disabled) with the same results.

When I say results I mean it sometimes stops a download at a somewhat random point as described above.

Did you modify the "speed" the progress viewer updates btw? It does seem to display correctly, although
in the release version the numbers sort of fly by, in b1 it sort of updates now and then (compared to before)..

I''m not able to provide proper test urls, and I guess they aren''t needed as "random" seems to be the keyword.
Alexander 02/27/2009 09:00 am
Jan,

Ok, thank you. We will try to reproduce this problem here.

Alexander
Jan 02/27/2009 10:35 am
> Jan,
>
> Ok, thank you. We will try to reproduce this problem here.

If it helps.. I tend to download using max 4 simultanous projects, 5 threads per project.
I use the numbered queue. I think the rest was at default values.

I don''t think any of the earlier versions has caused problems with this config, but I guess it is needed to reproduce the conditions.
The list contained 13+ items with 170-400 MB per file.
Jan 02/27/2009 10:39 am
If it has any significance.. MD shows my average download speed at 1.20MB/s (10 Mbit, but they boost it to guarantee the purchased speed).
Wez G 03/01/2009 02:49 am
I also just had a download stop (Showing the square like I had stopped it) and could not exit Mass Downloader, had to restart Windows.
Was downloading 15 files from Rapidshare all about 100MB, first time this has happened and I have downloaded a lot more over the last few days, pretty much all from Rapidshare.
Alexander 03/01/2009 07:12 am
Thank you for your reports.
I forwarded them to the developer. He will work to fix these problems ASAP.

Alexander
AlexanderBa 03/03/2009 10:10 am
Could you please test the updated build? You can download it from:
http://www.metaproducts.com/download/mdbsetup.exe
Please write us about the result.
Jan 03/03/2009 01:05 pm
> Could you please test the updated build? You can download it from:
> http://www.metaproducts.com/download/mdbsetup.exe
> Please write us about the result.

Well, it doesn''t seem to stop downloads for no reason (so far), but the
progress viewer is significantly slower than 3.6. Oh, and for some reason the number of threads seems to be ignored at times, as MD permanently reduce it to 1 on occation.

I guess this is intentional, but when this happens the speed is significantly decreased (to about 1/3 of normal).