Author Message
Henry Bai 12/20/2006 06:24 am
Hi!
I noticed a more serious bug when playing with MD..

I install MD and some other Download Accelerators together to test them out..

Everything was going very smoothly and then I tired to change the MOnitoring of IE in MD..
I checked the checkbox where it says "Alternate Monitoring Method" (or somethign similar) and clicked on Test Integration..

It came up with some Errors about mdhandler.dll or mdhelper.dll (can't remember whcih one) in my documents/downloads folder (which obviosuly the dll is not there).. Then the Checkbox (or is it the test Integration Button) is greyed out..

The scary part is that somehow, it deleted ALL the BHOs in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser Helper Objects as detected by Total Uninstall...

I don't know how and why it deleted everything in there, but I also noticed that on installation of MD, MD likes to create new default values or change default values of other BHOs in that registry key?

Do check out the bug. I think it is quite a serious one..

Thx
Henry Bai 12/20/2006 06:43 am
Hi.. I tried MD again, and I got the same error again when I choose NOT to use MD as the default download manager..
The error message is

The specific Module could not be found

my Documents/MDHELPER.dll [DllUnregisterServer]

Then it says iNtegration Successful.. But my BHOs are still there.. There was somethign that triggered the delete, but I have yet to find it.. But I do rememebr that one of the checkboxes or buttons are greyed out too when that happened..

Thanks
Henry Bai 12/20/2006 07:05 am
Oh! I gotit.. When you click yes, it deletes all the BHOs.. :(
Alexander 12/20/2006 07:59 am
Henry Bai,

Thank you for your investigation. Could you please tell me what BHOs did you have there? From what programs?

Best regards,
Alexander Bednyakov
MP Staff