Cannot find 'admmd.exe'

Author Message
Adrian 12/04/2006 06:20 am
When I close the options dialog, a dialog appears:

"Windows cannot find 'admmd.exe'. ..."

This happend while downloading. The options appeared to have been set
correctly and the download is continuing.

There is a file called 'admmd.exe' in my '\Program Files (x86)\Mass Downloader'
directory and it does seem to have execute permission.

Mass Dowloader 3.2.661
Windows Vista RTM (64-bit)
Alexander 12/04/2006 07:31 am
Adrian,

Thank you for your report.
We will test this problem under Vista 64bit and fix it ASAP.
Did you install/uninstall Mass Downloader at this system or this is the fresh installation of the program?

Best regards,
Alexander Bednyakov
MP Staff
Adrian 12/04/2006 11:19 am
> Did you install/uninstall Mass Downloader at this system or this is the fresh installation of the program?

I believe this Mass Downloader has been installed just once on my system.

Regards.
Mike pazda 02/14/2007 10:17 am
> > Did you install/uninstall Mass Downloader at this system or this is the fresh installation of the program?
>
> I believe this Mass Downloader has been installed just once on my system.
>
> Regards.
>

I have the same message, but in w2k, whenever I start Mass Downloader - If I add multiple files to MD the screen flickers and a windows is continuously displayed and flickers
Roddy MacKenzie 05/11/2007 12:17 pm
I'm getting the message from the new Mass Downloader 3.3 Release build on W2K Pro. No problem with the screen flickering.

Mine MD setup is an upgrade install over MD 3.2 SR2.

Roddy MacKenzie 06/26/2007 04:57 am
Another symptom of this problem is that MD loses the first or first few download requests passed from Offline Explorer unless MD is already loaded before the first request is made. I suspect this is because MD is handling the "Cannot find 'admmd.exe'" dialog box at the time.

New and unpleasant twist - I just tried uninstalling MD but was told the uninstaller failed because it "Cannot find 'admmd.exe'" This means my system is in BIG trouble.

I searched the registry for 'admmd.exe' and 'admmd' without success. Any suggestions on removing & reinstalling MD would be appreciated

Roddy
Alexander 06/26/2007 07:30 am
Roddy,

Thank you for your report.
Could you please install the updated version?
1. Please reboot your Windows
2. Download and install Mass Downloader over the existing version. The link is: http://www.metaproducts.com/download/mdsetup.exe
3. Run Mass Downloader and write us about the result.

Thank you!
Alexander Bednyakov
MP Staff
Roddy MacKenzie 06/26/2007 09:38 am
Alexander,

thanks for the rapis response.

I have now downloaded the latest version as per your link, installed it and rebooted.

Same problems, as I expected because I was already running MD 3.3.681

I am also running the latest version of OEE on a fully patched Win 2000 Pro system and using the latest version of Firefox as my main browser (IE is only used for the Windows / Office Update group of sites). My firewall & AV are from AVG. Temperature & fans are monitored by the final version of MBM. My network traffic is monitored by LAN Monitor.

I don't know of any other software I am running that might cause problems, but I will be happy to dig out the details if it might help solve this mystery.

Roddy
Alexander 07/05/2007 03:44 am
Roddy MacKenzie,

Could you please test the updated build? You can download it from:
http://www.metaproducts.com/download/betas/mdsetup.exe
Please write us about the result. Thank you.

Best regards,
Alexander Bednyakov
MP Staff
Roddy MacKenzie 07/05/2007 12:22 pm
Alexander,

I have just tried the MD 3.3.687 beta, with the same results - pop-up says cannot find... and the uninstaller says the same thing.

One other problem I forgot to mention - the installer shuts my machine down rather than performing a reboot. This may be a peculiarity of my setup, but nobody else's installer has this problem.

One other detail I should have mentioned in my previous reports is that once MD has got past the pop-up, everything else works perfectly.

Best regards,
Roddy MacKenzie
Tom 07/08/2007 07:33 pm
Using Opera 9.20 for Win 98se, suddenly when I click on a link, I am no longer offered the option of downloading the file using my registered version of 3.2.661. I suspect a recent Opera upgrade wiped out my ability to do this because it used to appear on a dropdown menu.

So If I Right Click on something, it wants to Download Now? And so forth. But no Opera option appears. On the other hand, if a web page has a Download Now button, clicking on it automatically invokes Opera and I am given no other options. This is the reverse of what used to occur.

So then I thought I would check my settings and all that. Perhaps something is not intergrated correctly with the browser. Let me cleck CHECK INTEGRATION. Whoops! Can't find previously unheard of file admmd.exe. Do I have such a thing? Why, yes. Yes, I do. It's in some place that seems to be: C:\WINDOWS\TEMP\{C545BB60-EAC5-11DB-ADB5-00C0F05B0254}

Now, wherever that is, that is where it put itself and wherever it is supposed to be is nowhere evident so I have no way to know where to move it. It's just that suddenly something has gone wrong and there is no way to know why or to find out how to fix it even though I do in fact have the allegedly missing file.

And it's damn inconvenient that I can't make the program that I have paid for and registered work as easily as HiDownload does for IE in the free trial version. If I wanted to hand crank my own software, I'd have been a programmer, not a customer trying to use what I've paid for.
Alexander 07/09/2007 10:32 am
Tom,

Thank you for writing us.

> So then I thought I would check my settings and all that. Perhaps something is not
> intergrated correctly with the browser. Let me cleck CHECK INTEGRATION. Whoops!
> Can't find previously unheard of file admmd.exe. Do I have such a thing? Why, yes.
> Yes, I do. It's in some place that seems to be:
> C:\WINDOWS\TEMP\{C545BB60-EAC5-11DB-ADB5-00C0F05B0254}

Could you please test the updated build? You can download it from:
http://www.metaproducts.com/download/betas/mdsetup.exe

After installation, please go to the Windows Start button menu, Run dialog. Please type:

massdown.exe /L

and click the OK button. After testing of this new version please find the c:\md.log file and send it to support@metaproducts.com with the short descritpion of the test result. Thank you for your help!

Best regards,
Alexander Bednyakov
MP Staff
Roddy MacKenzie 07/10/2007 12:45 pm
Alexander,

I followed the advice you gave to Tom and the annoying popup vanished.

I have sent the log by email to the support address.

Is there something different happening in the /L mode, apart from logging?

Best regards,

Roddy Mackenzie
Alexander 07/10/2007 01:20 pm
Roddy Mackenzie,

Thank you for the test!
I was going to ask you to try the updated Mass Downloader at your system after getting results from Tom.

> I followed the advice you gave to Tom and the annoying popup vanished.
> I have sent the log by email to the support address.

Very good, thank you!

> Is there something different happening in the /L mode, apart from logging?

No, just logging.

Sincerely,
Alexander
Tony 04/16/2009 02:30 am
Hi

I have been using Mass Downloader for several years without any issues, but last night the application froze and I discovered a message from my antivirus saying it had deleted a file because it was a virus. I reinstalled MD and got the same antivirus message. Can you lodge a formal complaint please as I suspect this is now going to affect a lot of people.

The file is - admmd.exe
The antivirus in - Norton Corporate 10.1.0.394, set to daily update
The Symantec url is - http://securityresponse.symantec.com/security_response/writeup.jsp?docid=2008-121617-3748-99&tabid=1

thanks
Alexander 04/16/2009 04:12 am
Tony,

Thank you for your report.
Since January we reported this problem to Symantec almost every week. They do not answer or reply something like "we cannot reproduce this problem, please send us screenshots". We did, no answer again.

Could you please help us and write them too using the online form https://submit.symantec.com/false_positive/index.html ?
May be they do not react because we are the vendor of Mass Downloader...

Thank you very much!
Best regards,
Alexander Bednyakov
MP Staff
Tony 04/16/2009 11:54 am
Alexander

I have reported this using my company ID, we are gold partners of Symantec, so if they ignore it this time there is no hope of sorting it out appart from re-writing the exe file :-(
Alexander 04/17/2009 01:19 am
Tony,

Thank you for your help.
We will re-write this exe file anyway.
The main goal now is to fix the problem ASAP.

Best regards,
Alexander
Alexander 04/22/2009 10:23 am
Could you please test the updated Mass Downloader?
We do not use exe-compressor for this file anymore. It sems NAV doesn''t like file compressors and finds this to be suspicious. The link of updated build is:

http://www.metaproducts.com/download/mdsetup.exe

Thank you!
Alexander