authentication

Author Message
n/a 07/10/2005 10:55 am
Hello,

I`ve integrated MD in OEP! If a file is bigger then 1024, it will be put in the MD queue. It`s a password protected site (settings set in the project properties of OEP)! The file in MD looks like:

http://username:password@website.com/folder1/zipfile.zip

But MD tells me that it can`t find host username!
When I go to the properties of the file, and click ok, it transforms into:

http://website.com/folder1/zipfile.zip

and downloads ok!!
Any suggestions?
TIA
Alexander 07/13/2005 07:02 am
Dear Sir / Madam,

Thank you for writing us.
I forwarded your message to Mass Downloader and Offline Explorer developers.
This problem will be fixed shortly.

Best regards,
Alexander Bednyakov
MP Staff
listenloudest 07/15/2005 06:48 am
I`ve had exactly this problem since at least mdbsetup_3.1.591_beta1 was released. I`ve tried with all the versions of OEP (3.6.1930 to 3.8.2048SR1) released since then and none fix the problem.

I have to reinstall mdsetup_3.0.577SR1.exe over the updated version to make it work again (with all versions of OEP). So I never got to use any of the improvements you add as it takes ages to go through hundreds of failed files in the MD queue choose properties then OK (only works one at a time) then add them back to the download queue with "control & +" for every site downloaded with OEP+MD and means they can`t be left to run overnight (as none of the files sent to MD download without the manual fix).

Also since 3.0.577SR1 no versions of MD (up to and including 3.1.607SR1) will download files with "&" in the name when using the IE right menu option to download all files with MD. The filenames show up in the dialog box with the "name" column showing only anything before the "&". Even though the "url" column shows the full url it isn`t passed to MD when it tries to download and so it fails.
Alexander 07/15/2005 07:00 am
Dear Sir / Madam,

Thank you for your comprehensive report.
The developers work to fix these problems.
I will inform you here about the progress.

Alexander
n/a 08/18/2005 02:49 pm
Any change yet?

Thanks!
Alexander 08/19/2005 02:06 am
We work to release the new version of Mass Downloader. This problem will be fixed in it.

Thanks,
Alexander
listenloudest 09/27/2005 10:41 am
> We work to release the new version of Mass Downloader. This problem will be fixed in it.
>
> Thanks,
> Alexander

I`ve just installed MD 3.2.623 Beta 1 and was VERY disappointed to find that the authentication bug has not been fixed.

This means I still have to keep using 3.0.577SR1 if I want it to integrate with any version of OEPro including 3.9.2104SR1, and miss out on any of the other fixes and features in the last 9 months.

I really hope you will make a concerted effort to fix this critcal bug as it renders every new version useless to anyone integrating it with OEPro. The two programs working properly toegther are fantastic, but with this bug are 100% unuseable together.

I look forward to another update soon :)
Alexander 10/04/2005 09:51 am
Could you please test the latest build?
It is uploaded today: http://www.metaproducts.com/download/mdbsetup.exe

Please write us about the result. Thank you.

Best regards,
Alexander Bednyakov
MP Staff
listenloudest 10/06/2005 10:40 am
Hi Alexander

Thanks for the quick turnaround.

I`ve tried it on a couple of membership websites and this latest version MD3.2.623Beta1 has fixed the bug.

Well done.