Probably several bugs

Author Message
Anonymous 04/23/2005 07:12 am
Hello all and Mass Downloader team separately.

I use Mass Downloader 3.0.577 SR1, and I`ve found some problems with it.

I`ve set up MD to add links from clipboard to the project list automatiucally. But it seems that MD has problems with URLs having single quote character (`) - MD does not add them to the project list automatically. Therefore I have to add such links manually. Also, when a file containg single quote character in the name is downloaded, MD sets the name of the file to something like "(1)" (without double quotes) and does not remove hidden attribute after the file is downloaded. This problem occurs if the file name was not changed manually.

Probably other problem is not a bug of MD, but it would be convenient if MD solved this problem. So, the problem is that if some server returns the HTTP-reply like the following (note that the filename is empty):
>> ...
>> Content-Disposition: attachment; filename=;
>> ...
then MD sets the name of the file to something like "(1)" (without double quotes). This problem occurs if the file name was not changed manually.
I propose to use the file name part of the URL in this case.

Thank you for the good product.
With best wishes,
Anonymous.
Alexander 04/23/2005 07:38 am
Thank you for writing us.

> I`ve set up MD to add links from clipboard to the project list automatiucally. But it seems
> that MD has problems with URLs having single quote character (`) - MD does not add them
> to the project list automatically. Therefore I have to add such links manually. Also, when a
> file containg single quote character in the name is downloaded, MD sets the name of the file
> to something like "(1)" (without double quotes) and does not remove hidden attribute after
> the file is downloaded. This problem occurs if the file name was not changed manually.

Could you please send me an URL for a test? Or please send it to support@metaproducts.com, if it is not for public access. Please add "MD problem" to the subject line.

> Probably other problem is not a bug of MD, but it would be convenient if MD solved this
> problem. So, the problem is that if some server returns the HTTP-reply like the following
> (note that the filename is empty):
> >> ...
> >> Content-Disposition: attachment; filename=;
> >> ...
> then MD sets the name of the file to something like "(1)" (without double quotes). This
> problem occurs if the file name was not changed manually.
> I propose to use the file name part of the URL in this case.

Could you please also provide us with a test URL?
Thank you!

Sincerely,
Alexander.
| Alexander Bednyakov
| MetaProducts Corporation
Anonymous 04/23/2005 09:23 am
Thank you for fast reply. I`ve sent a letter with sample URLs.

WBW,
Anonymous.
Alexander 04/28/2005 04:41 am
These problems are fixed in the latest build.
Could you please test it?
The link is: http://www.metaproducts.com/download/mdbsetup2.exe

Thank you for your help.
Sincerely,
Alexander