Downloaded files deleted after completion !

Author Message
n7Epsilon 09/01/2004 09:59 am
Hi everyone,
Ever since I started using Mass Downloader 2.7.534 SR2, I`ve been experiencing a very frustrating problem, I usually complete all my large downloads (20MB+) overnight since I am using dial-up and I use the connection for other tasks by day.
Just yesterday I used Mass Downloader for the first time for such a purpose to download (100+ MB) files overnight, setting the program to disconnect and shutdown itself and the PC afterwards at download completion. I woke up this morning just 5 minutes prior to download completion (it had been running overnight) to see all my downloads as "Done" and the last download finishing. 5 minutes later, the computer disconnects and shuts down as I set it.
Problem: I restart the computer to find half of my downloads marked as "Ready" despite being marked as "Done" 5 minutes earlier, also the downloaded files are gone and even the .Mass files have disappeared (they were there before shutdown) (Even the ones that remained at "Done", their files also have been erased somehow), is this a bug in Mass Downloader 2.7 SR2 ? Is this a virus or something? Note that I have ZoneLabs Security Suite fully updated and I have done a full system scan, also I have scanned for Spyware and Ad-ware and my PC was found clean...
I am running a dual-boot configuration, WinXPPro-Win98SE with Mass Downloader installed on W98SE. I use it when I download anything while in W98SE.
Please help me to prevent this from happening as it is very frustrating for me to wait for hours for a download to complete and then discover the file deleted after simply rebooting....
I have noticed that the downloaded file only gets deleted on Shutdown (or maybe during booting), that is to say, when I run the downloaded file *before* rebooting it works but after rebooting,... well it`s gone. Note: I save my downloads on an NTFS partition which I access thru W98SE by a special driver program that works perfectly (called NTFS for Windows 98) so its impossible for the files to be deleted by WININIT.INI as the driver runs in protected-mode only...
Even my file recovery tools couldn`t find anything.. Does anyone have this same problem ??
Please help....Thanks in advance..
Alexander 09/01/2004 10:12 am
Dear n7Epsilon,

Thank you for writing us.
No one has reported this before.
Could you please try to reproduce this problem with one change - please write files to the native Windows 98 FAT16 or FAT32 file system. You don`t need to download such big file please select a smaller one.
Please write me about the result. Thank you.

Best regards,
Alexander Bednyakov
MP Staff
n7Epsilon 09/01/2004 11:52 am
Well, I tried redownloading the smaller (2.76MB) of my overnight download files, I saved the downloaded file to a folder on a FAT32 partition and amazingly it works !! I rebooted the machine twice afterwards and the file is still there and it works !!
I then tried re-downloading the file to the same folder (overnight download folder) on the NTFS partition (accessed through Winternal`s NTFS For Windows 98) and opened it directly, it worked, then I tried to reboot the system....Odd enough, Windows 98 didn`t reboot, it just returned to the desktop normally without closing anything...I could also notice some signs of low priority hard disk activity, I had to close all the programs appearing in the system tray and closed all programs except for "explorer" by Win98SE`s CTRL-ALT-DEL (Close Program Dialog), then I clicked on "Start" and then "Shutdown" and then on "Ok", Finally the system shutdown, I rebooted it and opened Mass Downloader....the file is gone........not even the .mass file`s there as if nothing had been written to the hard drive all along.....Is the problem with the NTFS Driver.....?

As a note, I once used Mass Downloader to download a file to the same NTFS partition but to a different folder other than my overnight download folders and it worked, so that`s very odd...

Please reply......I hope I can solve this problem..
Alexander 09/02/2004 06:50 am
We cannot reproduce this problem at our test computers (we don`t use this Windows 98 - NTFS driver.)
I think it can be a problem of that driver.
Could you please make another test - please copy some file from FAT to NTFS under Windows 98 and then reboot Windows. It is a bit other thing than Mass Downloader does, but this test can help to find the cause.
Please write us about the result. Thank you.

Alexander
n7Epsilon 09/08/2004 08:02 pm
Hi,
I have reproduced this problem as you have suggested, several times, in fact. I created a ZIP file containing random text files and saved it on the desktop of Windows 98SE (FAT32), then I copied the ZIP file to the same download folder as the previous files, then I opened it from the NTFS partition under Windows 98SE directly after that, it was correctly copied, then I reboot and....it`s completely gone, this time I searched the NTFS partition using advanced file recovery tools (EasyRecovery and Active@ Undelete) and they both found nothing,.. not even traces of the deleted file...(I searched after rebooting for the file and found a shortcut to the file in the "Recent" folder under: C:\WINDOWS\Recent, but not the deleted file itself, though.)
This obviously proves that the file wasn`t written to the partition at all, but somehow Win98SE thought that it did (maybe it got written to RAM, the swap file or the cache, all of which get normally flushed on shutdown!).
I tried deleting one of my files from the NTFS partition under Windows 98SE using Windows Explorer manually (right-click and "Delete" to the recycle bin), the file was (apparently) deleted and appeared in the recycle bin...
I rebooted Windows 98SE, and strangely enough, the file`s back in my NTFS partition (as if it had not been deleted in the first place), yet it STILL remains in my Recycle Bin... very odd.....

Hope that helps...
Please reply.....Thanks for replying to my posts...
Alexander 09/09/2004 01:47 am
Thank you for your information.
It is obvious that the problem is in your Windows 98 -> NTFS driver.
Did you try to write/call to their support?

Alexander
Ken 01/02/2005 10:13 pm
I tried using MD2.6 on my pc woking with winXP sp1...
I downloaded a 40MB file from somwhere and when i returned to check the file after it has completed downloading all i found was something like this: <file name>.zip.mass

I tried removing the mass extension... the file opened but corrupted...

I never experienced until now... ive downloaded smaller files and they downloaded just fine...
Can you tell me what seems to be the problem? Thankz!
n7Epsilon 01/03/2005 12:59 am
I think that was solved in later versions...
Alexander 01/03/2005 07:18 am
Dear Ken,

Thank you for writing us.
Could you please download and test the latest 3.0 SR1 version?

Best regards,
Alexander Bednyakov
MP Staff