Corrupted download of big zip files - (cant open problem)

Author Message
ryan 03/29/2006 07:01 am
when downloading a big zip file under dial acess (w98) i OFTEN get trashed zip downloads. When i look inside the corrupted archive with a hex-editor i find old garbage from my deleted files.

I even can see massdownloader instantly "filling" rows in "Download Map" by just pausing and resuming the download.

It`s a very old problem! occurring aready in versions 2.1. My patience go away with my last 120 mb partial content zip failed download.

I don`t want spend my time anymore at this. someday i will look at this again to see if this problem was finaly solved.

good look.
Ryan 03/29/2006 07:01 am
obs:

The archive was reported successfully 100% done, although it never tried to overwrite the disk reserved space considered as "autofilled".

On each Pause-resume sequence increases the "autofilled" space up near the started threads space. (after a certain number of Pause-resume it stops to fill) - (the treads are not uniformely distributed in big archives, leaving a white block at the end of the "download map", where the filling happens). I was using a nondefault number of threads - 6. I have not changed the thread number during the download.

The original zipfile was not corrupted.

I hope it helps.
Alexander 03/29/2006 07:01 am
Dear Ryan,

Thank you for your report.
Could you please make the detailed downloading log file for one of these problem downloads?

For making the detailed log please check all settings under the Log tab in the Project properties dialog for the selected project. Start downloading. After it is done, if this error appeared, right-click in the Log view window and select "Save to file" item from the pop-up menu. Save file, pack it using WinZip or etc program and email it to support@metaproducts.com as attachment with a short description of a problem.

It will be good if you can reproduce this problem using not very big file.

Thank you for your help.

Sincerely,
Alexander.
| Alexander Bednyakov
| Senior Developer
| MetaProducts Corporation